Crashing on file/dir characters and other bugs

Ask for help and report issues with the Windows version of Transmission
npzeyer
Posts: 1
Joined: Sun May 20, 2018 7:50 am

Crashing on file/dir characters and other bugs

Postby npzeyer » Sun May 20, 2018 8:01 am

On Windows 10 x64 - running ver 2.93 (3c5870d4f5)

Certain characters in the directory or file names cause unknown file i/o errors or cause it to crash. A question mark character in the top directory of a torrent will cause it to crash for example.

A torrent had reliably caused an unknown file i/o error. I'm sorry I don't remember specifically what. I'm almost positive it was non-ascii and/or CJK characters. I had to switch to uTorrent temporarily for that.

Many times, when you exit the GUI, the main process is still alive. When you start it up again without killing the old background process, bad things happen. Such as sometimes, you add torrents it doesn't show up.

It doesn't remember the last directory you saved your torrent at.

It doesn't actually save your Preferences or torrent name changes until you properly/cleanly exit. If you change your preferences and Transmission crashes, it won't be saved.

edit:
the other is renaming torrents during the save process doesn't seem to work. That is, when you first open a torrent and select the location to save at, if you change the torrent name, to change the top level directory name of the tree, it doesn't change when it actually starts downloading. The workaround is the first save the location but not start the download. Then go to Torrent Properties and change/rename the directory there.

I don't know if this is only on some or all torrents, if you save at a location that already exists using the renaming method in Properties I stated above, and just start the torrent, it doesn't Verify first and just starts downloading. I have to explicitly verify.

Return to “Windows Support”