Transmission on Raspbian

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
creative-2008
Posts: 2
Joined: Fri Jun 15, 2018 2:08 pm

Transmission on Raspbian

Postby creative-2008 » Fri Jun 15, 2018 2:19 pm

I'm looking to get Transmission up and running on my Raspberry Pi 3B+ running the latest version of Raspbian. I followed this guide. https://www.addictivetips.com/media-str ... i-torrent/

It runs fine on the Pi itsself via remote desktop, however I receive this message when trying to access it via the web browser on another laptop on the same network.

Code: Select all

403: Forbidden
Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.

If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.



I checked the json file, and when I've changed the whitelist from true to false, it hasn't saved the changes. I noticed that when editing the json file and saving it, it asks if I want to 'Save modified buffer' Does that sound right?

pospec4444
Posts: 2
Joined: Sun Jun 17, 2018 2:57 pm

Re: Transmission on Raspbian

Postby pospec4444 » Mon Jun 18, 2018 6:22 am

Make sure the Transmission daemon is not running when changing the config file otherwise your changes will be over written.

Code: Select all

# service transmission-daemon stop


Source: Configure.

creative-2008
Posts: 2
Joined: Fri Jun 15, 2018 2:08 pm

Re: Transmission on Raspbian

Postby creative-2008 » Tue Jun 19, 2018 9:14 pm

That worked great - many thanks


Return to “Support”