Cannot connect to daemon except from the host

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
bibyfok
Posts: 2
Joined: Fri Apr 12, 2019 6:58 am

Cannot connect to daemon except from the host

Postby bibyfok » Fri Apr 12, 2019 7:10 am

Hello,

I have installed transmission on Windows with QT version. Daemon is running I can interact with it, with the web page, the QT client or the Remote GUI. However, it is impossible for me to connect to it except from the local host: Any other device on my network cannot see the page (no response) and I have a domain redirecting to my IP for all my services (Plex, Sonarr, Radarr etc) and I am not able aswell to connect to transmission.
To sum up:
  • I have forwarded port 9091 to the correct IP
  • I have edited settings.json to allow remote access (C:\Windows\ServiceProfiles\LocalService\AppData\Local\transmission-daemon)
  • I can access to transmission from the host thru: 127.0.0.1:9091 / localhost:9091 / 192.168.1.251:9091 // except DOMAINNAME.XXX:9091 --> Does not work
  • I cannot access to transmission from any other device on my network using 192.168.1.251:9091 / DOMAINNAME.XXX:9091
  • I tried to put false on all rpc restrictions but it does not change anything
  • I have no issue with any other service to access the host computer: Deluge/Qbittorent/Sonarr/Radarr/Plex, everything can be accessed from anywhere, especially thru my DOMAINNAME.XXX:PORTNUMBER
  • When I do changes to the settings.json I stop the service first...

Help would be greatly appreciated.

Settings.json file:

Code: Select all

{
    "alt-speed-down": 50,
    "alt-speed-enabled": false,
    "alt-speed-time-begin": 540,
    "alt-speed-time-day": 127,
    "alt-speed-time-enabled": false,
    "alt-speed-time-end": 1020,
    "alt-speed-up": 50,
    "bind-address-ipv4": "0.0.0.0",
    "bind-address-ipv6": "::",
    "blocklist-enabled": true,
    "blocklist-url": "https://silo.glasz.org/antip2p.list.gz",
    "cache-size-mb": 4,
    "dht-enabled": true,
    "download-dir": "E:\\Torrents",
    "download-queue-enabled": true,
    "download-queue-size": 300,
    "encryption": 1,
    "idle-seeding-limit": 7200,
    "idle-seeding-limit-enabled": true,
    "incomplete-dir": "Z:\\Telechargement\\Transmission\\",
    "incomplete-dir-enabled": false,
    "lpd-enabled": true,
    "message-level": 2,
    "peer-congestion-algorithm": "",
    "peer-id-ttl-hours": 6,
    "peer-limit-global": 500,
    "peer-limit-per-torrent": 100,
    "peer-port": 51413,
    "peer-port-random-high": 65535,
    "peer-port-random-low": 49152,
    "peer-port-random-on-start": false,
    "peer-socket-tos": "default",
    "pex-enabled": true,
    "port-forwarding-enabled": true,
    "preallocation": 1,
    "prefetch-enabled": true,
    "queue-stalled-enabled": true,
    "queue-stalled-minutes": 30,
    "ratio-limit": 2,
    "ratio-limit-enabled": true,
    "rename-partial-files": true,
    "rpc-authentication-required": true,
    "rpc-bind-address": "0.0.0.0",
    "rpc-enabled": true,
    "rpc-host-whitelist": "",
    "rpc-host-whitelist-enabled": false,
    "rpc-password": "xxxxxxxxxx",
    "rpc-port": 9091,
    "rpc-url": "/transmission/",
    "rpc-username": "xxxxxxx",
    "rpc-whitelist": "",
    "rpc-whitelist-enabled": false,
    "scrape-paused-torrents-enabled": true,
    "script-torrent-done-enabled": false,
    "script-torrent-done-filename": "",
    "seed-queue-enabled": false,
    "seed-queue-size": 150,
    "speed-limit-down": 100,
    "speed-limit-down-enabled": false,
    "speed-limit-up": 100,
    "speed-limit-up-enabled": false,
    "start-added-torrents": true,
    "trash-original-torrent-files": true,
    "umask": 0,
    "upload-slots-per-torrent": 14,
    "utp-enabled": true
}

bibyfok
Posts: 2
Joined: Fri Apr 12, 2019 6:58 am

Re: Cannot connect to daemon except from the host

Postby bibyfok » Fri Apr 12, 2019 9:10 am

Found the issue... I keep my post if anyone has the problem:
During my initial test I suspected Windows Firewall so I first created a rule allowing port 9091: No change. So I removed the rule and added a rule to allow Transmission Daemon.exe --> This worked !


Return to “Support”