Unable to update to Transmission 3.0 from 2.94 Build

Ask for help and report issues not specific to either the Mac OS X or GTK+ versions of Transmission
Post Reply
aniemand
Posts: 5
Joined: Wed Jun 27, 2012 12:20 am

Unable to update to Transmission 3.0 from 2.94 Build

Post by aniemand » Sun Jun 14, 2020 9:40 pm

Hi. Every time I open Transmission lately I'm told that there's a newer version available (3.0 vs the 2.94 build I'm using now). However, when I click on "Install Update," it appears as if everything is going smoothly until the very end where I'm greeted with the following error message: "An error occurred while extracting the archive. Please try again later."

I've been trying this now for a couple of weeks and I'm met by the same error message. Any help? Do I need to delete this version just download version 3.0? If I do, though, I'll lose all my Transmission settings, which is why I haven't just yet.

Thanks for any input on helping me to upgrade.

livings124
Transmission Developer
Posts: 3141
Joined: Fri Jan 13, 2006 8:08 pm

Re: Unable to update to Transmission 3.0 from 2.94 Build

Post by livings124 » Sat Jun 20, 2020 4:25 pm

You can replace the old version downloaded from the website with 3.00 safely.

Post Reply